Heads up to fellow 's! Newest glitch-soc has upgraded dependencies that require nodejs v14, while mastodon docs still recommend installing v12.
On Ubuntu or Debian, edit the relevant parts in /etc/apt/sources.list.d/nodesource.list
and run sudo apt update & sudo apt upgrade.

Follow

After doing so, do the regular bundle install; yarn install, restart services, etc. And you shouldn't get any errors.

· · Web · 0 · 0 · 0
Sign in to participate in the conversation
Cathode Church

A place for trans makers, coders, tinkerers and dreamers.